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Version	2.0	
In	version	2.0,	our	primary	goal	has	been	to	simplify	the	transfer	of	the	music	
library	between	desktop	computers	and	iPads.		The	older	wireless	
synchronization	is	still	supported,	but	a	faster	document	sharing	method	
through	iTunes	is	now	recommended.	

There	are	now	two	different	variations	on	the	companion	desktop	
application:		Forzando	Companion	and	Forzando	Desktop.		

Forzando	Companion	includes	the	legacy	wireless	synchronization	methods	
used	in	version	1.0	and	later	and	still	requires	the	Bonjour	library.		
Additionally,	Forzando	Companion	supports	the	new	synchronization	
method,	which	is	an	export	for	iTunes,	relying	on	iTune’s	document	sharing	
features.	

Forzando	Desktop	supports	only	this	latter	method	of	synchronization,	
however,	it	has	less	complicated	system	requirements.		Bonjour	is	not	
required,	nor	is	a	wireless	network.	

Also	new	in	version	2.0	is	support	for	.m4a	files	in	addition	to	.mp3	files.	

Getting	Started	
Forzando	is	a	PDF	and	MP3	organizer	designed	to	let	you	take	your	sheet	
music	library	with	you	wherever	you	go.			Though	tailored	for	sheet	music,	
Forzando	may	also	act	as	a	general-purpose	PDF	viewer.	

The	Forzando	system	consists	of	two	applications:		Forzando,	a	PDF	
reader/MP3	player	for	the	iPad,	and	Forzando	Companion,	a	desktop	
application	for	managing	and	transferring	your	music	library.		

This	document	describes	how	to	use	Forzando	to	establish	and	maintain	your	
sheet	music	library	on	one	or	more	devices.	
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System	Requirements	(Forzando	Companion)	

Forzando	Companion	requires	JRE	1.6	or	later,	Bonjour,	and	the	Bonjour	Java	
library	‘dns_sd.jar’.		Therefore	the	minimum	system	requirements	are:	

Macintosh:	

• Snow	Leopard	(10.6)	or	later.		
• JRE	1.6	or	later.	

Note:		 Forzando	Companion	will	not	run	on	Mac	OS	X	10.5	or	
earlier.	

PC:	

• Windows	XP	SP2	or	better	or	Windows	Vista	or	Windows	7.	
• JRE	1.6	or	later	(available	from	www.java.com)	
• Bonjour	(available	from	www.apple.com)	

Note:		 A	wireless	network	is	required	for	synchronization	on	
either	platform.	

System	Requirements	(Forzando	Desktop)	

Forzando	Desktop	requires	JRE	1.6	or	later	running	on	Mac	or	Windows.			
Files	are	transferred	to	the	iPad	through	the	file	sharing	features	of	iTunes.		
Without	iTunes,	Forzando	Desktop	cannot	send	files	to	the	iPad.	

Obtaining	Forzando	Companion	or	Forzando	Desktop	

To	obtain	either	Forzando	Desktop	or	Forzando	Companion,	select	the	
appropriate	download	from	www.drakeapplications.com/Downloads.		The	
application	download	resides	in	a	zipped	folder	(Forzando_Installer_2.0.zip).		
Run	the	installer	and	follow	the	directions	on	screen	to	install	or	upgrade.	

Running	the	Installer	
First, double-click ForzandoInstaller.zip to launch the installer.  When prompted, 
select to install either Forzando Companion or Forzando Desktop.  Here are 
some guidelines to choose which version is right for you: 
 

• If you already have an older version of Forzando Companion, you should 
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probably choose to install Forzando Companion. (Forzando Desktop will 
install over Forzando Companion if that’s what you want.) 

o If you plan only to synchronize through iTunes using file sharing, 
choose Forzando Desktop, which does not require Bonjour. 

o If you plan to synchronize wirelessly at any time, you must choose 
Forzando Companion. 

 
Next, select the destination directory where Forzando should be installed. 

• If you select a directory where Forzando is already installed, the installer 
will ask if you want to upgrade. 

• If you select an empty directory, the entire application will be installed 
there. 

• If you select a directory that is not an existing Forzando directory and is 
not empty, the installer will prompt if you want to install Forzando in a child 
directory. 

o If you choose “Install Anyway”, Forzando will be installed over any 
existing files in the directory you chose. 

o If you choose “Install in New Folder”, the installer will create a 
Forzando folder inside of the folder you chose and install Forzando 
there. 

o  
When the installer completes, you will see the message “Install complete.” or 
“Update complete.”  Forzando Companion or Forzando Desktop is now installed 
on your computer.	

Note:		 Unless	otherwise	noted,	the	remaining	document	describes	how	to	
use	both	Forzando	Companion	and	Forzando	Desktop.		For	
simplicity,	we	will	mention	only	Forzando	Companion.	

Launching	Forzando	Companion	

After	downloading	and	installing	Forzando	Companion,	open	the	“Forzando”	
folder.		To	launch	Forzando	Companion,	double-click	the	application	
“Forzando”.	



Forzando	Users	Guide	

 - 4	-	

Additional	Installation	Instructions	for	Windows	(Forzando	
Companion	Only)	

Forzando	Companion	requires	Java	1.6	and	Bonjour	in	order	to	run.		If	it	fails	
to	launch,	the	most	likely	reason	is	that	one	or	both	of	these	components	are	
not	properly	installed.		

Verifying	that	Java	is	Present	
To	test	for	Java,	run	‘cmd’	and	type:	

java	-version	

If	the	version	shown	is	not	at	least	1.6,	you	will	need	to	install	or	upgrade	
Java.		Java	is	available	from	Sun	Microsystems	(now	Oracle)	at:	
http://java.com/en/download/manual.jsp	

Note:		 If	you	both	Java	and	Bonjour	are	missing,	be	sure	to	install	
Java	first,	or	dns_sd.jar	file	may	not	be	installed	with	Bonjour,	
and	you	will	have	to	reinstall	Bonjour	after	installing	Java.	

Verifying	that	Bonjour	is	Present	
To	verify	that	the	Java	component	for	Bonjour	is	installed,	check	that	
dns_sd.jar	exists	at:	

C:\Program	Files\Java\jre6\lib\ext\dns_sd.jar	

If	the	file	is	not	present	after	installing	Bonjour,	you	may	be	able	to	copy	it	
from:	

C:\Program	Files\Bonjour\dns_sd.jar	

If	the	above	file	does	not	exist	after	installing	Bonjour,	uninstall	Bonjour	and	
reinstall	it.	

Bonjour	for	Windows	is	available	from	Apple	at:		

http://support.apple.com/kb/dl999	

Note:		 We	recommend	verifying	the	path	to	dns_sd.jar	before	
running	Forzando	Companion	for	the	first	time,	even	if	
Bonjour	is	already	installed	on	your	system.	
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Using	Forzando	Companion	and	Forzando	
Desktop	

Introducing	the	Music	Library	

A	typical	music	library	consists	of	scores	in	PDF	format,	each	of	which	may	be	
associated	with	an	MP3	file.		These	scores	are	then	organized	into	user-
defined	collections	(reminiscent	of	play	lists)	which	can	be	transferred	to	one	
or	more	devices.	

Note:		 The	PDFs	and	MP3s	are	actually	transferred	to	the	device	when	you	
sync,	so	you	do	not	have	to	have	an	internet	connection	to	view	or	
listen	to	your	scores	after	the	sync	completes.	

Any	PDF	or	MP3	you	add	to	the	music	library	will	be	copied	from	its	original	
source	to	the	“library”	directory	of	Forzando	Companion	and	will	appear	as	a	
row	in	the	“Music	Library”	interface.	

A	First	Look	at	the	User	Interface	

To	launch	Forzando	on	your	desktop,	double-click	the	“Forzando”	application	
icon	in	the	expanded	folder.		Upon	successful	launch,	you	will	see	the	
following	window:	
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The	user	interface	is	composed	of	a	split	view	containing	the	Music	Library	
Selector	to	the	left	and	the	content	view	to	the	right.		In	general,	selecting	an	
item	in	from	the	Music	Library	Selector	results	in	displaying	its	contents	in	
the	content	view.	

When	“Music	Library”	is	selected,	all	of	the	scores	in	your	library	are	listed	in	
the	content	view.		Individual	collections	you	have	defined	are	listed	
subordinate	to	the	“Collections”	heading.		Selecting	one	of	these	collections	
displays	its	contents	in	the	content	view;	however	selecting	the	“Collections”	
heading	itself	has	no	effect.			Similarly,	connected	devices	are	displayed	
subordinate	to	the	“Devices”	heading.	

Initially,	your	music	library	is	empty	and	no	collections	are	defined.	
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Building	the	Music	Library	

Undoubtedly	you	will	want	to	start	building	your	sheet	music	library	right	
away.		The	following	topics	describe	the	steps	required	to	import	PDFs,	
associate	them	with	MP3s,	and	organize	your	sheet	music	library	into	
collections.	

Adding	a	Single	Score	
To	add	one	score	to	your	music	library,	do	the	following:	

Step	1. Select	“Music	Library”	from	the	Music	Library	Selector.	
Step	2. Select	“File->Import	Score…”	or	press	Command-I.		A	file	

browser	window	appears.	
Step	3. Navigate	to	the	PDF	you	want	to	add	and	select	it.	
Step	4. Click	“Open”.		The	PDF	is	copied	to	Forzando’s	“library”	folder	

and	a	row	for	the	score	appears	in	the	content	view.	

Note:		 If	you	select	a	PDF	with	the	same	name	as	an	existing	PDF,	Forzando	
will	overwrite	the	existing	score	with	the	new	one	rather	than	add	a	
new	score.	

Step	5. If	you	want	to	change	the	title	of	the	score	or	add	the	name	of	the	
composer	or	the	genre	of	the	piece,	select	the	relevant	column	
for	that	score’s	row	and	enter	a	new	title,	composer,	or	genre.	

Associating	an	Audio	File	with	a	Score	
To	associate	a	single	MP3	or	M4A	with	a	score,	do	the	following:	

Step	1. Select	the	score	in	the	music	library.	
Step	2. Select	“File->Attach	Audio…”.		A	file	browser	window	appears.	
Step	3. Navigate	to	the	MP3/M4A	you	want	to	attach	to	the	score	and	

select	it.	
Step	4. Click	“Open”.		The	MP3/M4A	is	copied	to	Forzando’s	“library”	

folder	and	a	checkmark	(√)	is	displayed	in	the	row	for	that	score	
to	indicate	that	an	MP3/M4A	is	attached.	

Adding	Many	Scores	and	MP3s	At	Once	
Oftentimes	it	may	be	more	convenient	to	add	many	PDFs	and/or	audio	files	at	
once.		The	Forzando	Companion	allows	this	operation	through	drag-and-drop	
from	the	Finder	to	the	content	pane.		Performing	the	drag-and-drop	causes	
each	PDF	to	be	imported	into	the	music	library,	while	each	audio	file	is	
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associated	to	the	PDF	having	the	same	name.		For	example,	consider	the	
following	files:	

• MyScore.pdf	
• YourScore.pdf	
• MyScore.mp3	
• YourScore.m4a	

If	all	three	of	these	files	are	dropped	on	the	content	view,	“MyScore.pdf”	and	
“YourScore.pdf”	will	be	added	to	the	library	and	“MyScore.mp3”	will	be	
associated	with	“MyScore.pdf”.		YourScore.m4a	will	be	associated	with	
YourScore.pdf.	

Organizing	Scores	into	Collections	

Creating	a	New	Collection	
A	collection	is	simply	a	grouping	of	scores	in	your	music	library	under	a	
particular	name.		Manipulating	collections	does	not	change	the	contents	of	the	
music	library	itself.		To	create	a	new	collection,	do	the	following:	

Step	1. Select	“File->New	Collection…”	or	press	Command-N.		A	dialog	
box	appears	prompting	for	the	name	of	the	collection.	

Step	2. Enter	a	name	for	the	collection.	
Step	3. Click	“OK”.	

The	new	collection	appears	beneath	the	“Collections”	heading	in	the	Music	
Library	Selector.	

Step	4. From	the	“Music	Library”,	select	one	or	more	scores	and	drag	
them	from	the	content	pane	to	the	new	collection.	

Step	5. Let	up	on	the	mouse	to	complete	the	drop.		The	selected	scores	
are	now	placed	in	the	collection.	

Note:		 You	may	view	the	contents	of	a	collection	at	any	time	by	selecting	
the	collection	from	the	Music	Library	Selector.	

Creating	a	Collection	from	the	Current	Selection	
To	save	time,	you	can	preselect	a	set	of	scores	and	create	a	new	collection	
having	those	scores	added	to	it	upon	creation.		Simply	do	the	following:	

Step	1. Select	the	scores	you	want	in	the	new	collection.	
Step	2. Select	“File->New	Collection	from	Selection…”.	
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Step	3. Enter	a	name	for	the	new	collection	in	the	box	that	appears.	

Adding	Scores	to	a	Collection	and	the	Music	Library	at	the	Same	Time	
If	you	know	you	would	like	to	add	one	or	more	scores	and/or	MP3s	to	a	
particular	collection	in	addition	to	the	music	library,	you	can	add	these	
documents	to	both	the	collection	and	the	music	library	at	the	same	time.		
Simply	select	the	collection	before	dragging	the	files	to	the	content	view,	as	
follows:	

Step	1. Select	the	collection	from	the	Music	Library	Selector	into	which	
you	want	to	add	the	scores.	

Step	2. Drag	the	PDFs	and	MP3s	you	want	to	add	from	the	Finder	into	
the	content	view.	

Step	3. Add	any	additional	data	(title,	composer,	genre,	etc.)	to	each	new	
row	in	the	collection	as	you	see	fit.	

Reordering	a	Collection	
After	adding	scores	to	a	collection,	you	may	determine	that	you	would	like	the	
score	to	appear	in	a	different	order	within	the	collection.		To	reorder	the	
scores	within	a	collection,	do	the	following:	

Step	1. Select	the	collection	from	the	Music	Library	Selector	that	you	
would	like	to	reorder.	

Step	2. Select	“Edit->Reorder	Collection…”.		The	following	dialog	box	
appears:	
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Step	3. Select	a	score	to	move	within	the	list.	
Step	4. Click	“Move	Up”	to	move	the	score	higher	in	the	list	or	click	

“Move	Down”	to	move	the	score	lower.	
Step	5. Repeat	until	the	scores	are	in	the	desired	order.	
Step	6. Click	“OK”.	

Note:		 The	scores	will	be	ordered	as	specified	in	the	dialog	box	when	you	
sync	with	your	iPad.		The	changes	to	the	order	will	not	be	visible	in	
the	content	view	until	you	refresh	that	view	by	switching	to	another	
collection.		If	you	have	a	filter	or	are	sorting	by	column,	no	changes	
will	be	shown	to	the	order	of	the	scores	in	the	content	view.	

Managing	the	Music	Library	

From	time	to	time,	you	may	decide	to	remove	a	score	or	collection	from	your	
music	library,	or	you	may	want	to	remove	a	score	from	a	particular	collection.	

Deleting	a	Score	
To	remove	a	score	entirely	from	the	music	library,	do	the	following.	

Step	1. Select	“Music	Library”	from	the	Music	Library	Selector.	
Step	2. Select	the	score	or	scores	you	want	to	delete.	
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Step	3. Select	“Edit->Delete…”	and	confirm	that	you	want	to	remove	the	
score	or	scores.	

Note:		 Deleting	a	score	removes	it	from	the	music	library,	deletes	its	PDF	
and	optional	MP3,		and	removes	it	from	all	collections.	

Removing	Just	the	MP3	from	a	Score	
To	remove	an	MP3	from	a	score,	do	the	following:	

Step	1. Select	the	score	or	scores	from	which	you	want	to	strip	the	MP3.	
Step	2. Select	“Edit->Remove	Audio…”.	
Step	3. Confirm	the	removal.	

Forzando	will	report	how	many	audio	files	were	removed.	

Modifying	a	Score	
If	you	have	a	new	version	of	a	score	and	you	want	to	replace	the	old	version	
in	the	music	library	with	this	new	version,	do	the	following:	

Step	1. Verify	that	the	name	of	the	modified	score’s	PDF	is	exactly	the	
same	as	the	name	of	existing	score’s	PDF.	

Step	2. Select	“Music	Library”	from	the	Music	Library	Selector.	
Step	3. Drag	the	score	to	the	content	view.	

Deleting	a	Collection	
To	delete	a	collection	do	the	following:	

Step	1. Select	the	collection	to	delete	from	the	Music	Library	Selector.	
Step	2. Select	“Edit->Delete	Collection…”.	
Step	3. Confirm	the	deletion.	

Note:		 Deleting	a	collection	simply	removes	the	association	of	the	scores	
with	the	collection;	it	does	not	remove	the	scores	or	any	associated	
PDFs	or	MP3s	from	the	music	library.	

Renaming	a	Collection	
To	rename	a	collection,	do	the	following:	

Step	1. Select	the	collection	to	rename	from	the	Music	Library	Selector.	
Step	2. Select	“Edit->Rename	Collection…”.	
Step	3. Enter	a	new	name	in	the	box	that	appears.	
Step	4. Click	“OK”.	
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Removing	a	Score	from	a	Collection	
To	remove	a	score	from	a	collection,	do	the	following:	

Step	1. Select	the	collection	from	the	Music	Library	Selector.	
Step	2. Select	the	score	or	scores	to	remove	from	the	content	view.	
Step	3. Select	“Edit->Delete…”.		The	score	will	be	removed	from	the	

collection.	

Note:		 Removing	a	score	from	a	collection	does	not	delete	it	from	the	
music	library,	nor	does	it	remove	its	PDF	or	audio	file.	

Viewing	a	Score	
To	view	a	score	with	the	default	PDF	viewer,	do	the	following:	

Step	1. Select	the	score	from	the	content	view.	
Step	2. Select	“File->Open	Score…”	or	press	Command-O.	

Playing	an	Attached	Audio	File	
To	play	an	attached	MP3/M4A	with	the	default	application,	do	the	following:	

Step	3. Select	the	score	from	the	content	view.	
Step	4. Select	“File->Play	Score…”	or	press	Command-P.	

Synchronizing	with	Devices	(Forzando	Companion	Only)	

Forzando	Companion	allows	multiple	devices	to	synchronize	with	its	music	
library	over	a	wireless	network.		Forzando	uses	Bonjour	for	identifying	the	
devices	with	zero-configuration.		While	this	method	is	still	supported	in	
Forzando	Companion,	the	iTunes	file	sharing	method	described	in	the	section	
“Exporting	the	Music	Library	for	Synchronization	with	iTunes”	is	now	the	
recommended	synchronization	method.	

To	synchronize	a	set	of	collections	with	a	device	do	the	following:	

Step	1. With	the	Forzando	Companion	running,	select	the	“Sync”	tab	
from	the	“Music	Library”	button	on	Forzando	running	on	your	
device.		You	should	see	a	message	indicating	that	the	Forzando	
service	has	been	published.	

Step	2. After	a	few	seconds,	a	new	device	should	appear	beneath	the	
“Devices”	heading	on	the	Music	Library	Selector.		It	may	take	up	
to	15	seconds	before	the	device	is	recognized.	
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Step	3. Select	the	device	from	the	Music	Library	Selector.		The	content	
view	shows	a	list	of	all	available	collections.		Those	collections	
that	are	already	on	the	device	are	checked.	

Step	4. Turn	each	collection	on	or	off	as	desired.		(Collections	that	are	
checked	will	be	put	on	the	device	and	collections	that	are	not	
checked	will	be	removed	from	the	device.)	

Step	5. Select	“Sync->Sync	with	Device…”	or	press	Command-Y.	
Step	6. Upon	successful	sync,	a	box	appears	with	the	message	“The	sync	

completed	successfully.”		Simply	dismiss	this	message	box.	
Step	7. Select	either	the	“Scores”	tab	or	the	“Collections”	tab	in	Forzando	

running	on	your	device.		This	should	un-publish	the	device	and	
remove	it	from	the	listing	under	the	“Devices”	heading	of	the	
Music	Library	Selector.	

Note:		 On	occasion,	the	operation	in	Step	6	above	may	not	remove	the	
device	from	the	Music	Library	Selector.		Should	this	occur,	you	can	
tap	the	sync	tab	again	to	republish	the	service	and	then	select	one	of	
the	other	tabs.		Usually	this	is	sufficient	to	remove	the	device	from	
the	list.		If	the	device	still	persists	in	the	list,	restart	Forzando	on	
your	device.	
	
Important:	
Be	sure	to	repeat	step	1	(publishing	the	Forzando	service)	between	
synchronizations.	

The	amount	of	time	required	for	synchronization	depends	on	the	size	of	your	
music	library	and	the	speed	of	your	wireless	network.		We	have	seen	typical	
throughput	rates	of	100-150	kilobytes	per	second,	though	your	mileage	may	
vary.	

Exporting	the	Music	Library	for	Synchronization	with	iTunes	

Forzando	Companion	and	Forzando	Desktop	both	support	exporting	the	
music	library	for	use	with	iTunes	file	sharing	in	the	Forzando	app.		The	export	
steps	themselves	do	not	require	the	iPad	to	be	connected	or	for	Forzando	to	
be	active	on	the	iPad.		To	export	the	music	library	do	the	following:	

Step	1. Create	a	folder	in	your	file	system	where	you	would	like	to	place	
the	exported	music	library.	



Forzando	Users	Guide	

 - 14	-	

Step	2. In	Forzando	Companion	or	Forzando	Desktop,	select	“File	->	
Export	All	for	iTunes…”	

Step	3. Select	the	folder	you	created	in	Step	1.	
	

To	share	the	exported	music	library	with	Forzando	on	your	iPad,	do	the	
following:	

Step	1. Connect	your	iPad	to	your	computer	through	the	USB	cable.	
Step	2. Close	or	put	Forzando	in	the	background.	
Step	3. Launch	iTunes.	
Step	4. In	iTunes,	select	your	iPad	and	view	the	list	of	apps	installed	on	

your	iPad.	
Step	5. Find	Forzando	in	the	list	of	apps	that	support	file	sharing.	
Step	6. Click	“Add”	and	select	all	of	the	files	in	the	folder	you	used	for	

the	export.	
Step	7. Launch	Forzando	(or	activate	it).		You	will	see	the	following	

message:	
	“Forzando	has	loaded	a	database	synchronized	from	iTunes.”		

Your	music	library	and	all	collections	are	now	available	in	the	Forzando	app.	

Saving	the	Window	Size	

To	save	the	size	of	Forzando	Companion’s	startup	window	at	launch,	set	the	
size	of	the	window	as	desired	and	select	“File->Save	Preferences”.	
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Credits	

Forzando	Companion	and	Forzando	Desktop	use	the	SQLite	JDBC	connector	
library	available	at	www.xerial.org,	which	is	licensed	under	the	Apache	2.0	
license.	


