Forzando 53

A portable music library for the musician on the go.
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Getting Started

Welcome to Forzando, a PDF and MP3 organizer designed to let you take your
sheet music library with you wherever you go. Though tailored for sheet
music, Forzando may also act as a general-purpose PDF viewer.

The Forzando system consists of two applications: Forzando, a PDF
reader/MP3 player for the iPad; and Forzando Companion, a desktop
application for managing and transferring your music library.

This document describes how to use Forzando to establish and maintain your
sheet music library on one or more devices.

System Requirements

Forzando Companion requires JRE 1.6 (32 bit), Bonjour, and the Bonjour Java
library ‘dns_sd.jar’. Therefore the minimum system requirements are:

Macintosh:

* Snow Leopard (10.6).
* JRE 1.6 (Bundled with Snow Leopard).

Note: Forzando Companion will not run on Mac OS X 10.5 or
earlier.

PC:

* Windows XP SP2 or better or Windows Vista or Windows 7.
* JRE 1.6 (available from www.java.com)
* Bonjour (available from www.apple.com)

Note: A wireless network is required for synchronization on
either platform.

Obtaining Forzando Companion

To obtain Forzando Companion, select the appropriate download from
www.drakeapplications.com/Downloads. The application download resides
in a zipped folder (Forzando.zip). Expand the zip file in the directory in which
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you would like to install the application. This will create a “Forzando” folder
containing the application and necessary folders.

Launching Forzando Companion

After downloading and extracting Forzando Companion, open the “Forzando”
folder. To launch Forzando Companion, double-click “Forzando.jar”.

Additional Installation Instructions for Windows

Forzando Companion requires Java 1.6 and Bonjour in order to run. If it fails
to launch, the most likely reason is that one or both of these components are
not properly installed.

Verifying that Java is Present
To test for Java, run ‘cmd’ and type:

java -version

If the version shown is not at least 1.6, you will need to install or upgrade
Java. Java is available from Sun Microsystems (now Oracle) at:
http://java.com/en/download /manualjsp

Note: If you both Java and Bonjour are missing, be sure to
install Java first, or dns_sd.jar file may not be installed
with Bonjour, and you will have to reinstall Bonjour
after installing Java.

Verifying that Bonjour is Present
To verify that the Java component for Bonjour is installed, check that
dns_sd.jar exists at:

C:\Program Files\Java\jre6\lib\ext\dns_sd.jar

If the file is not present after installing Bonjour, you may be able to copy it
from:

C:\Program Files\Bonjour\dns_sd.jar

If the above file does not exist after installing Bonjour, uninstall Bonjour and
reinstall it.
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Bonjour for Windows is available from Apple at:

http://support.apple.com/kb/d1999

Note: = We recommend verifying the path to dns_sd.jar before
running Forzando Companion for the first time, even if
Bonjour is already installed on your system.
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Using Forzando Companion

Introducing the Music Library

A typical music library consists of scores in PDF format, each of which may be
associated with an MP3 file. These scores are then organized into user-
defined collections (reminiscent of play lists) which can be transferred to one
or more devices.

Note:  The PDFs and MP3s are actually transferred to the
device when you sync, so you do not have to have an
internet connection to view or listen to your scores
after the sync completes.

Any PDF or MP3 you add to the music library will be copied from its original
source to the “library” directory of Forzando Companion and will appear as a
row in the “Music Library” interface.

A First Look at the User Interface

To launch Forzando on your desktop, double-click the “Forzando” application
icon in the expanded folder. Upon successful launch, you will see the
following window:
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B Forzando Companion

File Edit Sync

Filter: ’I ‘ Clear
Music Library ! | . ] Name ] Composer | Genre | Date Modified
Collections

Devices

The user interface is composed of a split view containing the Music Library
Selector to the left and the content view to the right. In general, selecting an
item in from the Music Library Selector results in displaying its contents in
the content view.

When “Music Library” is selected, all of the scores in your library are listed in
the content view. Individual collections you have defined are listed
subordinate to the “Collections” heading. Selecting one of these collections
displays its contents in the content view; however selecting the “Collections”
heading itself has no effect. Similarly, connected devices are displayed
subordinate to the “Devices” heading.

Initially, your music library is empty and no collections are defined.
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Building the Music Library

Undoubtedly you will want to start building your sheet music library right
away. The following topics describe the steps required to import PDFs,
associate them with MP3s, and organize your sheet music library into
collections.

Adding a Single Score
To add one score to your music library, do the following:

Step 1. Select “Music Library” from the Music Library Selector.

Step 2. Select “File->Import Score...” or press Ctrl-I. A file browser
window appears.

Step 3. Navigate to the PDF you want to add and select it.

Step 4. Click “Open”. The PDF is copied to Forzando’s “library” folder
and a row for the score appears in the content view.

Note: If you select a PDF with the same name as an existing
PDF, Forzando will overwrite the existing score with
the new one rather than add a new score.

Step 5. If you want to change the title of the score or add the name of the
composer or the genre of the piece, select the relevant column
for that score’s row and enter a new title, composer, or genre.

Associating an MP3 with a Score
To associate a single MP3 with a score, do the following:

Step 1. Select the score in the music library.

Step 2. Select “File->Attach Audio...”. A file browser window appears.

Step 3. Navigate to the MP3 you want to attach to the score and select it.

Step 4. Click “Open”. The MP3 is copied to Forzando’s “library” folder
and a checkmark (V) is displayed in the row for that score to
indicate that an MP3 is attached.

Adding Many Scores and MP3s At Once

Oftentimes it may be more convenient to add many PDFs and/or MP3s at
once. The Forzando Companion allows this operation through drag-and-drop
from Windows Explorer to the content pane. Performing the drag-and-drop
causes each PDF to be imported into the music library, while each MP3 is
associated to the PDF having the same name. For example, consider the
following files:
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* MyScore.pdf
* YourScore.pdf
* MyScore.mp3

If all three of these files are dropped on the content view, “MyScore.pdf” and
“YourScore.pdf” will be added to the library and “MyScore.mp3” will be
associated with “MyScore.pdf”.

Organizing Scores into Collections

Creating a New Collection

A collection is simply a grouping of scores in your music library under a
particular name. Manipulating collections does not change the contents of the
music library itself. To create a new collection, do the following:

Step 1. Select “File->New Collection...” or press Ctrl-N. A dialog box
appears prompting for the name of the collection.

Step 2. Enter a name for the collection.

Step 3. Click “OK”.

The new collection appears beneath the “Collections” heading in the Music
Library Selector.

Step 4. From the “Music Library”, select one or more scores and drag
them from the content pane to the new collection.

Step 5. Let up on the mouse to complete the drop. The selected scores
are now placed in the collection.

Note:  You may view the contents of a collection at any time
by selecting the collection from the Music Library
Selector.

Creating a Collection from the Current Selection
To save time, you can preselect a set of scores and create a new collection
having those scores added to it upon creation. Simply do the following:

Step 1. Select the scores you want in the new collection.
Step 2. Select “File->New Collection from Selection...”.
Step 3. Enter a name for the new collection in the box that appears.
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Adding Scores to a Collection and the Music Library at the Same Time

If you know you would like to add one or more scores and/or MP3s to a
particular collection in addition to the music library, you can add these
documents to both the collection and the music library at the same time.
Simply select the collection before dragging the files to the content view, as
follows:

Step 1. Select the collection from the Music Library Selector into which
you want to add the scores.

Step 2. Drag the PDFs and MP3s you want to add from Windows
Explorer into the content view.

Step 3. Add any additional data (title, composer, genre, etc.) to each new
row in the collection as you see fit.

Reordering a Collection

After adding scores to a collection, you may determine that you would like the
score to appear in a different order within the collection. To reorder the
scores within a collection, do the following:

Step 1. Select the collection from the Music Library Selector that you
would like to reorder.
Step 2. Select “Edit->Reorder Collection...”. The following dialog box

appears:
Reorder Collection
: | ———
Agngs Dei . Move Up )
Gloria p .
Sanctus . Move Down |

7 Y '
¢ Cancel ) OK )
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Step 3. Select a score to move within the list.

Step 4. Click “Move Up” to move the score higher in the list or click
“Move Down” to move the score lower.

Step 5. Repeat until the scores are in the desired order.

Step 6. Click “OK”.

Note:  The scores will be ordered as specified in the dialog box when you
sync with your iPad. The changes to the order will not be visible in
the content view until you refresh that view by switching to another
collection. If you have a filter or are sorting by column, no changes
will be shown to the order of the scores in the content view.

Managing the Music Library

From time to time, you may decide to remove a score or collection from your
music library, or you may want to remove a score from a particular collection.

Deleting a Score
To remove a score entirely from the music library, do the following.

Step 1. Select “Music Library” from the Music Library Selector.

Step 2. Select the score or scores you want to delete.

Step 3. Select “Edit->Delete...” and confirm that you want to remove the
score or scores.

Note: Deleting a score removes it from the music library,
deletes its PDF and optional MP3, and removes it from
all collections.

Removing Just the MP3 from a Score
To remove an MP3 from a score, do the following:

Step 1. Select the score or scores from which you want to strip the MP3.
Step 2. Select “Edit->Remove Audio...”.
Step 3. Confirm the removal.

Forzando will report how many audio files were removed.

Modifying a Score
If you have a new version of a score and you want to replace the old version
in the music library with this new version, do the following:
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Step 1.

Step 2.
Step 3.

Verify that the name of the modified score’s PDF is exactly the
same as the name of existing score’s PDF.

Select “Music Library” from the Music Library Selector.

Drag the score to the content view.

Deleting a Collection
To delete a collection do the following:

Step 1.
Step 2.
Step 3.

Note:

Select the collection to delete from the Music Library Selector.
Select “Edit->Delete Collection...”.
Confirm the deletion.

Deleting a collection simply removes the association of
the scores with the collection; it does not remove the
scores or any associated PDFs or MP3s from the music
library.

Renaming a Collection
To rename a collection, do the following:

Step 1.
Step 2.
Step 3.
Step 4.

Select the collection to rename from the Music Library Selector.
Select “Edit->Rename Collection...”.

Enter a new name in the box that appears.

Click “OK”.

Removing a Score from a Collection
To remove a score from a collection, do the following:

Step 1.
Step 2.
Step 3.

Note:

Select the collection from the Music Library Selector.

Select the score or scores to remove from the content view.
Select “Edit->Delete...”. The score will be removed from the
collection.

Removing a score from a collection does not delete it
from the music library, nor does it remove its PDF or
MP3.

Viewing a Score
To view a score with the default PDF viewer, do the following:

Step 1.
Step 2.

Select the score from the content view.
Select “File->Open Score...” or press Ctrl-O.
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Playing an Attached MP3
To play an attached MP3 with the default application, do the following:

Step 3.
Step 4.

Select the score from the content view.
Select “File->Play Score...” or press Ctrl-P.

Synchronizing with Devices

Forzando Companion allows multiple devices to synchronize with its music
library over a wireless network. Forzando uses Bonjour for identifying the
devices with zero-configuration. To synchronize a set of collections with a
device do the following:

Step 1.

Step 2.

Step 3.

Step 4.

Step 5.

Step 6.

Step 7.

Note:

With the Forzando Companion running, select the “Sync” tab
from the “Music Library” button on Forzando running on your
device. You should see a message indicating that the Forzando
service has been published.

After a few seconds, a new device should appear beneath the
“Devices” heading on the Music Library Selector. It may take up
to 15 seconds before the device is recognized.

Select the device from the Music Library Selector. The content
view shows a list of all available collections. Those collections
that are already on the device are checked.

Turn each collection on or off as desired. (Collections that are
checked will be put on the device and collections that are not
checked will be removed from the device.)

Select “Sync->Sync with Device...” or press Ctrl-Y.

Upon successful sync, a box appears with the message “The sync
completed successfully.” Simply dismiss this message box.
Select either the “Scores” tab or the “Collections” tab in Forzando
running on your device. This should un-publish the device and
remove it from the listing under the “Devices” heading of the
Music Library Selector.

On occasion, the operation in Step 6 above may not
remove the device from the Music Library Selector.
Should this occur, you can tap the sync tab again to
republish the service and then select one of the other
tabs. Usually this is sufficient to remove the device
from the list. If the device still persists in the list,
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restart Forzando on your device.

Important:
Be sure to repeat step 1 (publishing the Forzando
service) between synchronizations.

The amount of time required for synchronization depends on the size of your
music library and the speed of your wireless network. We have seen typical
throughput rates of 100-150 kilobytes per second, though your mileage may
vary.

Saving the Window Size

To save the size of Forzando Companion’s startup window at launch, set the
size of the window as desired and select “File->Save Preferences”.

Running from the Command Line

You can run Forzando Companion from the command line in order to view
debug information as well as the progress of individual file transfers during
sync. To start Forzando Companion from the command line, do the following:

Step 1. Open cmd, also known as “Command Prompt”. (You may have to
choose “Run” and enter cmd from the Start Menu).

Step 2. cd to the directory containing Forzando.jar.

Step 3. Enter “java -jar Forzando.jar”. Forzando Companion will launch
as usual.
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Credits

Forzando Companion uses the SQLite JDBC connector library available at
www.xerial.org, which is licensed under the Apache 2.0 license.
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